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File menu commands

The File menu offers the following commands:

Open Local Open a HTML file from local disk.
Open Remote Download a HTML file from Internet.
Reload Reload the current HTML file.
Batch 
Download

Batch download HTML files.

Setup 
Homepage

Setup your own home page.

Setup Hot 
List File

Setup current hot list file.

Edit HTML for
View

Edit the current HTML file for viewing.

Edit 
Configuration
File

Edit the I-Comm configuration file.

Edit Hot List 
File

Edit the current hot list file.

Save As 
HTML

Save the current HTML file with images to disk.

Save As ASCII Save the current HTML file as a plain text file to disk.
Print Prints the current HTML document.
Print Preview Displays the current HTML file as it would appear when printed.
Print Setup Selects a printer and printer connection.
Exit Exit I-Comm





File menu commands

The File menu offers the following commands:

Upload Upload files to the remote computer.
Download Download files from the remote computer.
Protocol Setup the file transfer protocol.
Print Setup Selects a printer and printer connection.
Exit Exit I-Comm





Navigate menu commands

The Navigate menu offers the following commands:

Home Page Go back to home page.
Previous Go to previous HTML page.
Next Go to next HTML page.
Goto Site Go to a remote site on Internet.
Hot Site Open the hot site list.
Stop Transfer Stop the next file transfer.



Edit menu commands

The Edit menu offers the following commands:

Copy Copies data from the I-Comm Terminal window to the clipboard.
Paste Pastes data from the clipboard into the I-Comm Terminal window.
Clear Clear I-Comm Terminal window screen.



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.
Font Setup text fonts for I-Comm Browser.
Transfer 
Dialog Type

Choose file transfer status dialog type.

Load Inline 
Images

Enable or disable inline image downloading.

Use Local 
Cache Files

Enable or disable local disk file caching.

Clean Local
Cache Files

Clean cache files on local hard disk.

Clean 
Cache On 
Exit

Clean cache files on exit I-Comm.

Save 
Settings 
On Exit

Save settings on exit I-Comm. 



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.
Font Setup I-Comm Terminal text font.
Color Setup color VT100 emulation for I-Comm Terminal.
Gray 
Shades

Set I-Comm Terminal background color to gray.

Black & 
White

Set I-Comm Terminal background color to black.

Emulation Setup emulation for I-Comm Terminal.
Save 
Settings 
On Exit

Save settings on exit I-Comm. 

Communication menu commands

The Communication menu offers the following commands:

Phone Book Open the dialing phone book.
Manual Dial Dial a number manually.
Hangup Hangup the phone line.
Auto Answer Enable modem auto answer mode.
Com Port 
Setup

Setup communication port.

Dial Setup Setup modem dial commands.
Modem Setup Setup modem type.
Host Program
Setup

Setup file download, remove commands.

Internet Host 
Program

Choose Internet host program for I-Comm.

Host Tickle 
Interval

Setup host tickle interval to prevent hangup.



Communication menu commands

The Communication menu offers the following commands:

Phone Book Open the dialing phone book.
Manual Dial Dial a number manually.
Hangup Hangup the phone line.
Auto Answer Enable modem auto answer mode.
Com Port 
Setup

Setup communication port.

Dial Setup Setup modem dial commands.
Modem Setup Setup modem type.
Set Break 
Signal

Set modem break signal on.

Clear Break 
Signal

Clear modem break signal





Window menu commands

The Window menu offers the following commands, which enable you to arrange I-Comm 
Browser and Terminal windows:

Cascade Arranges Browser and Terminal windows in an overlapped 
fashion.

Tile Arranges Browser and Terminal windows in non-overlapped
tiles.

Window 1, 
2, ...

Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with I-Comm: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version number of I-Comm.



Exit command (File menu)

Use this command to end your I-Comm session.





Clear command (Edit menu)

Use this command to clear I-Comm Terminal screen.





Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if
there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts
Keys: ALT+C



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    This 
command is unavailable if the clipboard is empty.

Shortcuts
Keys: ALT+V



Toolbar command (Options menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in I-Comm, such as Navigate Home Page. 

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in I-Comm,

To hide or display the Toolbar, choose Toolbar from the Options menu.

Click To

Print the active document.



Status Bar command (Options menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the I-Comm window.    To display or hide the 
status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.





Cascade command (Window menu)

Use this command to arrange Browser and Terminal windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange Browser and Terminal windows in a non-overlapped fashion.





1, 2, ... command (Window menu)

I-Comm displays Browser and Terminal windows at the bottom of the Window menu.    A 
check mark appears in front of the document name of the active window.    Choose a 
document from this list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using I-Comm and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of I-
Comm.



Context Help command 

Use the Context Help command to obtain help on some portion of I-Comm.    When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and 
question mark.    Then click somewhere in the I-Comm window, such as another Toolbar 
button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Minimize command (application Control menu)

Use this command to reduce the I-Comm window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    I-Comm determines which
window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    I-Comm determines 
which window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Ruler command (View menu)

<< Write application-specific help here. >>



Choose Font dialog box

<< Write application-specific help here. >>



Choose Color dialog box

<< Write application-specific help here. >>



makehm IDR_HIDR_,0x2000 resource.h

If the IDR_ symbol for one of your document types is, for example, IDR_CHARTTYPE, then the
help context i.d. generated by MAKEHM will be HIDR_CHARTTYPE.

Note, AppWizard defines the HIDR_DOC1TYPE help context i.d. used by this help topic for the
first document type supported by your application.    AppWizard produces an alias in the .HPJ 
file for your application, mapping HIDR_DOC1TYPE to the HIDR_ produced by MAKEHM for 
that document type. >>





No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the 
AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for each 
AFX_HIDP_xxx value.    For example, AFX_HIDP_INVALID_FILENAME is the help topic for the 
Invalid Filename message box. >>

                  





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that I-Comm is sending output to the 
printer.    The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format.    The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

<< Write application-specific help here. >>

    





Open Local command (File menu)

Use this command to open a HTML file on local disk.This command presents a file selection 
dialog, where you may specify the file you want to open.





Open Remote command (File menu)

Use this command to open a HTML file from Internet. 





Setup Hot List File command (File menu)

Use this command to select current hot list file. This command presents a file selection 
dialog, where you may specify the hot list file you want to use. 





Save As HTML command (File menu)

Use this command to save the current HTML with inline images to disk. This command 
presents a file selection dialog, where you may specify the directory and file name you want 
to save to.    The saved files can be viewed later using I-Comm or other WEB browser. 





Save As ASCII command (File menu)

Use this command to save the current HTML file in plain text format to disk. This command 
presents a file selection dialog, where you may specify the directory and file name you want 
to save to.      





Setup Homepage command (File menu)

Use this command to setup your own homepage. This command presents a file selection 
dialog, where you may specify the file you want to use as homepage. 





Edit Hot List File command (File menu)

Use this command to edit the current hot list file. I-Comm hot list file is in plaintext format.    
The first item of each line is HTTP address, the remaining text on each line is the title of 
current hot list.    You can change the title text. 





Batch Download command (File menu)

Use this command to batch download HTML files. 





How To Register I-Comm

Why register I-Comm ?

              a. You get the FULL FEATURE "registered" version of the 
                        software in which the "registration" dialog will not pop 
                        up every time you start and exit the program
              b. You will get free upgrades until I-Comm version 1.99.
              c. Priority for adding new features to I-Comm.
              d. It will support us continuously improving I-Comm.    We plan
                        to support HTML3 and Netscape tags before version 1.99.
              e. You will receive discounts on our other internet related 
                        products. (We have an off-line mail reader and a HTML 
                        editor coming up)

How to register I-Comm ?

        You can register I-Comm either by FAX or by MAIL.
=======================================================
============
        Cost:
            * US $39.95 for commercial users 
            * US $29.95 for non-commercial users 
            * Special: $10 discount for full-time college students.
                  Please send US $19.95 and a photo copy of both sides of 
                  your current student ID along with the registration form.
            * Site license and education discount are also available, 
                  for detail information, send your inquiry to:
                                    icomm@talentcom.com
=======================================================
============
        1. To Register By Mail:
                Send check or money order with registration form to:
                                    Talent Communications, Inc.
                                    P.O.Box 611476 
                                    San Jose, CA 95161-1476
                                    U.S.A.
              * Make check or money order payable to 
                      Talent Communications, Inc. in US dollars.
=======================================================
============
        2. To Register By Fax:
                Fill out and sign following form and send it with the
                registration form to: (408)437-0738 via FAX.

                Method of Payment:    ( ) MasterCard      ( ) Visa      ( ) Am. Express
                Card # : ____________________________________________
                Exp. Date : _________________________________________
                Your Name : _________________________________________
                Your Signature : ____________________________________
                Date : ______________________________________________

=======================================================
============



                                    I-Comm Registration Form
=======================================================
============
Name:                                                                                                          Date:
=======================================================
============
Company Name (if any):
=======================================================
============
E-Mail Address (required):
=======================================================
============
Street Address:
=======================================================
============
City:                                                                                                        State: 
=======================================================
============
Zip:                                                                          Country:
=======================================================
============
Phone Number (including Country Code):
=======================================================
============
Fax Number (including Country Code):
=======================================================
============

Where did you hear about I-Comm:
                1. Internet newsgroup, 
                        please specify:____________________________________
                2. CompuServe
                3. AOL
                4. Other online service provider,
                        please specify: ____________________________
                5. I-Comm advertising flyers
                6. Newspapers, magazines
                      please specify:____________________________________
                7. From a friend
                8. Others, please specify: ____________________________
=======================================================
============

Where did you obtain I-Comm software:
                1. I-Comm ftp sites (from best.com or netcom.com)
                2. SimTel
                3. CICA
                4. CompuServe
                5. AOL
                6. Other ftp site, please specify: ____________________
                7. From a friend
                8. Others, please specify: ____________________________
=======================================================
============



What kind of Internet account do you have:
                1. SLIP/PPP
                2. Unix shell account
                3. VAX account
                4. Freenet account
=======================================================
============

Upon receiving this form and payment, Talent Communications, Inc.
will send you an I-Comm license file via E-Mail.    Please double
check you E-Mail address.

Thank you for registering I-Comm.
=======================================================
============

 





Edit HTML for View command (File menu)

Use this command to edit the current HTML file for view. 





Edit Configure File command (File menu)

Use this command to edit I-Comm configuration file "i-comm.ini". 





Reload command (File menu)

Use this command to reload the current HTML file.



<< Write application-specific help here. >>

    





Upload command (File menu)

Use this command to upload a file.      This command presents a file selection dialog, where 
you may specify the file you want to upload.





Download command (File menu)

Use this command to download a file from remote computer. 





Protocol command (File menu)

Use this command to select the file transfer protocol., where you specify the printer and its 
connection.



<< Write application-specific help here. >>

    





Font command (Options menu)

Use this command to change I-Comm Terminal font.      This command presents a font 
selection dialog, where you may specify the font you want to use for I-Comm Terminal.





Color command (Option menu)

Use this command to set color VT100 emulation for I-Comm Terminal. 





Gray Shades command (Options menu)

Use this command to set the I-Comm Terminal background to gray. 





Black & White command (Options menu)

Use this command to set the I-Comm Terminal background to black. 





Emulation command (Options menu)

Use this command to set I-Comm Terminal emulation. 





Save Settings On Exit command (Options menu)

Use this command to enable or disable setting save on exit I-Comm.



<< Write application-specific help here. >>

    





Font command (Options menu)

Use this command to change I-Comm Browser font.      This command presents a font 
selection dialog, where you may specify fonts you want to use for I-Comm Browser.





Load Inline Images command (Option menu)

Use this command to enable or disable Inline image downloading. 





Clean Cache On Exit command (Option menu)

Use this command to enable or disable clean cache files on exit I-Comm. 





Use Local Cache Files command (Option menu)

Use this command to enable or disable local disk file caching. 





Transfer Dialog Type command (Option menu)

Use this command to choose the file transfer status dialog for I-Comm Browser. 





Clean Local Cache Files command (Options menu)

Use this command to clean local cache files.



<< Write application-specific help here. >>

    





Phone Book command (Communication menu)

Use this command to open I-Comm phone number directory.      This command presents a 
phone book window, where you may add, edit, delete, save dialup phone numbers.





Manual Dial command (Communication menu)

Use this command to manual dial a phone number. 





Hangup command (Communication menu)

Use this command to hang up the phone line. 





Auto Answer command (Communication menu)

Use this command to enable or disable the modem automaticallyanswer the incoming phone
calls. 





Com Port Setup command (Communication menu)

Use this command to setup the com port for I-Comm. 





Dial Setup command (Communication menu)

Use this command to setup the modem dial command for I-Comm. 





Modem Setup command (Communication menu)

Use this command to setup the modem type. 





Internet Host Program command (Communication menu)

Use this command to choose which Internet host program to use with I-Comm.    You can use 
either icomhost, lynx or www. But If you want to use HTML FORM to do search or give 
feedback to some Internet WWW server,you need to use icomhost. 





Host Setup command (Communication menu)

Use this command to setup file remove command and Z-modem download command for I-
Comm.

File Remove Command:is the command I-Comm will send to the shell account each time 
after file downloading.    The most common command is "rm", "rm -f" etc.    To prevent failing 
of excuting this command, I-Comm will issue a "unalias rm" command before issuing the File 
Remove Command.    If this field is blank, I-Comm will issuing "unalias rm; rm -f" command to
the shell account.

Z-Modem Download Command:is the command I-Comm will send to the    shell account to
download files.    The most common command is "sz".    "sz" command options can also be 
specified here, such as "sz -be".    You may want to check with your system Admin to find out 
the right "sz" you need. If this field is blank, I-Comm will issuing    "sz" command to the shell 
account.

Command Prefix:is the command I-Comm will send to the shell account before issuing any 
other commands.    The most common use of this    command is to change directory in shell 
account before downloading files. For example, by putting "cd temp" in this field will cause I-
Comm to change to "temp" directory everytime when a file is downloaded.    In other word,    
all the files will be downloaded into the "temp" directory in your shell account.    If this field is
blank, I-Comm will not issuing    any command before file downloading and all the files    will 
be downloaded into the current directory in the shell account.

Command Suffix:is the command I-Comm will send to the shell account after issuing all 
other commands.    The most common use of this    command is to setup the "rm" alias. For 
example, by putting "alias rm 'rm -i'" in this field will cause I-Comm to alias rm to "rm -i" 
after file downloading. If this field is blank, I-Comm will not issuing    any command after file 
downloading.

Order of Excution:
 1. Command Prefix 
 2. Z-Modem Download Command 
 3. File Remove Command 
 4. Command Suffix  





Host Tickle Interval command (Communication menu)

Use this command to setup host tickle interval to prevent phoneline hang up. 





Set Break Signal command (Communication menu)

Use this command to set the break signal on. 





Clear Break Signal command (Communication menu)

Use this command to clear the break signal.



<< Write application-specific help here. >>

    





Home Page command (Navigate menu)

Use this command to go back the home page.





Previous command (Navigate menu)

Use this command to goto the previous HTML page. 





Next command (Navigate menu)

Use this command to goto the next HTML page. 





Goto Site command (Navigate menu)

Use this command to goto a remote site on Internet. 





Hot Site command (Navigate menu)

Use this command to open the hot site list. 





Stop Transfer command (Navigate menu)

Use this command to stop the next image file transfer request.



<< Write application-specific help here. >>

    




